#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{4}-\d{2}-\d{2}\s\d{2}:\d{2}:\d{2})\s(\w{1,})\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s(.*)\s(DELIVERED|NONDELIVERED|ONBOX|SPLITMESSAGE|NOTDELIVERED|DEFERRED|PMM)\s(.*)\s(.*)"
Local $sString = "2019-03-05 08:24:51 IRJCT A2794e73e787142:X server.example.com <> ime.priimek-prejemnik@example.com NOTDELIVERED None" & @CRLF & _
"" & @CRLF & _
"2019-03-06 23:04:26 IACPT 44F78V1Wqpz1nryx server.example.com ime.priimek-posiljateljt@example.com "ime.pri+imek-prejemnik"@gmail.com Subject maila =?€|\ NONDELIVERED None" & @CRLF & _
"" & @CRLF & _
"2019-03-01 09:36:04 IACPT 449jS32DJTzMkvX server.example.com ime.priimek-posiljateljt&t.gr+o=up@example.com ka,kro&be+=rger@example.com Subject maila =?€|\1 DELIVERED Priponka_0686.pdf,Aktivni-izvadak007FBB04.docx,image001.jpg None"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")