import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{2}-\\d{2}\\s\\d{2}:\\d{2}:\\d{2})\\s(\\w{1,})\\s([A-Za-z0-9.,-_:@;]*)\\s([A-Za-z0-9.,-_:@;]*)\\s([A-Za-z0-9.,-_:@;+\"&]*)\\s([A-Za-z0-9.,-_:@;+\"&]*)\\s(.*)\\s(DELIVERED|NONDELIVERED|ONBOX|SPLITMESSAGE|NOTDELIVERED|DEFERRED|PMM)\\s(.*)\\s(.*)";
final String string = "2019-03-05 08:24:51 IRJCT A2794e73e787142:X server.example.com <> ime.priimek-prejemnik@example.com NOTDELIVERED None\n\n"
+ "2019-03-06 23:04:26 IACPT 44F78V1Wqpz1nryx server.example.com ime.priimek-posiljateljt@example.com \"ime.pri+imek-prejemnik\"@gmail.com Subject maila =?€|\\ NONDELIVERED None\n\n"
+ "2019-03-01 09:36:04 IACPT 449jS32DJTzMkvX server.example.com ime.priimek-posiljateljt&t.gr+o=up@example.com ka,kro&be+=rger@example.com Subject maila =?€|\\1 DELIVERED Priponka_0686.pdf,Aktivni-izvadak007FBB04.docx,image001.jpg None";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}