use strict;
my $str = '2019-03-05 08:24:51 IRJCT A2794e73e787142:X server.example.com <> ime.priimek-prejemnik@example.com NOTDELIVERED None
2019-03-06 23:04:26 IACPT 44F78V1Wqpz1nryx server.example.com ime.priimek-posiljateljt@example.com "ime.pri+imek-prejemnik"@gmail.com Subject maila =?€|\\ NONDELIVERED None
2019-03-01 09:36:04 IACPT 449jS32DJTzMkvX server.example.com ime.priimek-posiljateljt&t.gr+o=up@example.com ka,kro&be+=rger@example.com Subject maila =?€|\\1 DELIVERED Priponka_0686.pdf,Aktivni-izvadak007FBB04.docx,image001.jpg None';
my $regex = qr/(\d{4}-\d{2}-\d{2}\s\d{2}:\d{2}:\d{2})\s(\w{1,})\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s(.*)\s(DELIVERED|NONDELIVERED|ONBOX|SPLITMESSAGE|NOTDELIVERED|DEFERRED|PMM)\s(.*)\s(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}