import Foundation
let pattern = #"(\d{4}-\d{2}-\d{2}\s\d{2}:\d{2}:\d{2})\s(\w{1,})\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s(.*)\s(DELIVERED|NONDELIVERED|ONBOX|SPLITMESSAGE|NOTDELIVERED|DEFERRED|PMM)\s(.*)\s(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2019-03-05 08:24:51 IRJCT A2794e73e787142:X server.example.com <> ime.priimek-prejemnik@example.com NOTDELIVERED None
2019-03-06 23:04:26 IACPT 44F78V1Wqpz1nryx server.example.com ime.priimek-posiljateljt@example.com "ime.pri+imek-prejemnik"@gmail.com Subject maila =?€|\ NONDELIVERED None
2019-03-01 09:36:04 IACPT 449jS32DJTzMkvX server.example.com ime.priimek-posiljateljt&t.gr+o=up@example.com ka,kro&be+=rger@example.com Subject maila =?€|\1 DELIVERED Priponka_0686.pdf,Aktivni-izvadak007FBB04.docx,image001.jpg None
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)