const regex = /(\d{4}-\d{2}-\d{2}\s\d{2}:\d{2}:\d{2})\s(\w{1,})\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s([A-Za-z0-9.,-_:@;+"&]*)\s(.*)\s(DELIVERED|NONDELIVERED|ONBOX|SPLITMESSAGE|NOTDELIVERED|DEFERRED|PMM)\s(.*)\s(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2}\\s\\d{2}:\\d{2}:\\d{2})\\s(\\w{1,})\\s([A-Za-z0-9.,-_:@;]*)\\s([A-Za-z0-9.,-_:@;]*)\\s([A-Za-z0-9.,-_:@;+"&]*)\\s([A-Za-z0-9.,-_:@;+"&]*)\\s(.*)\\s(DELIVERED|NONDELIVERED|ONBOX|SPLITMESSAGE|NOTDELIVERED|DEFERRED|PMM)\\s(.*)\\s(.*)', 'gm')
const str = `2019-03-05 08:24:51 IRJCT A2794e73e787142:X server.example.com <> ime.priimek-prejemnik@example.com NOTDELIVERED None
2019-03-06 23:04:26 IACPT 44F78V1Wqpz1nryx server.example.com ime.priimek-posiljateljt@example.com "ime.pri+imek-prejemnik"@gmail.com Subject maila =?€|\\ NONDELIVERED None
2019-03-01 09:36:04 IACPT 449jS32DJTzMkvX server.example.com ime.priimek-posiljateljt&t.gr+o=up@example.com ka,kro&be+=rger@example.com Subject maila =?€|\\1 DELIVERED Priponka_0686.pdf,Aktivni-izvadak007FBB04.docx,image001.jpg None`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}