#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\"']?)(.*?)\1\s*(#.*)"
Local $sString = ""test" # comment ---> group1: test group2: # comment" & @CRLF & _
"test # comment ---> group1: test group2: # comment" & @CRLF & _
""t#est" # comment ---> group1: t group2: #est" # comment"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")