const regex = new RegExp('([\\"\\']?)(.*?)\\1\\s*(#.*)', 'gm')
const str = `"test" # comment ---> group1: test group2: # comment
test # comment ---> group1: test group2: # comment
"t#est" # comment ---> group1: t group2: #est" # comment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}