re = /([\"']?)(.*?)\1\s*(#.*)/m
str = '"test" # comment ---> group1: test group2: # comment
test # comment ---> group1: test group2: # comment
"t#est" # comment ---> group1: t group2: #est" # comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end