using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\""']?)(.*?)\1\s*(#.*)";
string input = @"""test"" # comment ---> group1: test group2: # comment
test # comment ---> group1: test group2: # comment
""t#est"" # comment ---> group1: t group2: #est"" # comment";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}