import re
regex = re.compile(r"([\"']?)(.*?)\1\s*(#.*)", flags=re.MULTILINE)
test_str = ("\"test\" # comment ---> group1: test group2: # comment\n"
"test # comment ---> group1: test group2: # comment\n"
"\"t#est\" # comment ---> group1: t group2: #est\" # comment")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")