#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bhe(?!\S)"
Local $sString = "he is hey! he!" & @CRLF & _
"he is he!" & @CRLF & _
"he hey! he!" & @CRLF & _
"" & @CRLF & _
"he is hey!" & @CRLF & _
"he is he!" & @CRLF & _
"he" & @CRLF & _
"testhey" & @CRLF & _
"testhe" & @CRLF & _
" test he is hey!! he"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")