const regex = new RegExp('\\bhe(?!\\S)', 'gm')
const str = `he is hey! he!
he is he!
he hey! he!
he is hey!
he is he!
he
testhey
testhe
test he is hey!! he`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}