using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhe(?!\S)";
string input = @"he is hey! he!
he is he!
he hey! he!
he is hey!
he is he!
he
testhey
testhe
test he is hey!! he";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}