re = /\bhe(?!\S)/m
str = 'he is hey! he!
he is he!
he hey! he!
he is hey!
he is he!
he
testhey
testhe
test he is hey!! he'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end