import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhe(?!\\S)";
final String string = "he is hey! he!\n"
+ "he is he!\n"
+ "he hey! he!\n\n"
+ "he is hey!\n"
+ "he is he!\n"
+ "he\n"
+ "testhey\n"
+ "testhe\n"
+ " test he is hey!! he";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}