const regex = /(?i)([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*@([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*\.([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*@([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*\\.([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*', 'gm')
const str = `seanie@gleason.tech`;
const subst = `$1******@$2******.$3**`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);