use strict;
my $str = 'seanie@gleason.tech';
my $regex = qr/(?i)([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*@([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*\.([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*/mp;
my $subst = '$1******@$2******.$3**';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";