$re = '/(?i)([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*@([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*\.([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*/m';
$str = 'seanie@gleason.tech';
$subst = "$1******@$2******.$3**";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;