import re
regex = re.compile(r"(?i)([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*@([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*\.([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*", flags=re.MULTILINE)
test_str = "seanie@gleason.tech"
subst = "$1******@$2******.$3**"
result = regex.sub(subst, test_str)
if result:
print(result)