re = /(?i)([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*@([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*\.([a-zA-Z0-9. _%+-])[a-zA-Z0-9. _%+-]*/m
str = 'seanie@gleason.tech'
subst = '$1******@$2******.$3**'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result