using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-zA-Z])\d+|\d+(?=[a-zA-Z])";
string input = @"I need this number inside my wor5d, but also this word3 and this 4word, but not this 1 and not this 555.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}