use strict;
my $str = 'I need this number inside my wor5d, but also this word3 and this 4word, but not this 1 and not this 555.';
my $regex = qr/(?<=[a-zA-Z])\d+|\d+(?=[a-zA-Z])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}