re = /(?<=[a-zA-Z])\d+|\d+(?=[a-zA-Z])/m
str = 'I need this number inside my wor5d, but also this word3 and this 4word, but not this 1 and not this 555.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end