import re
regex = re.compile(r"(?<=[a-zA-Z])\d+|\d+(?=[a-zA-Z])", flags=re.MULTILINE)
test_str = "I need this number inside my wor5d, but also this word3 and this 4word, but not this 1 and not this 555."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")