using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"nothing( *)(?:^|)(new|to|at|another|really|about|perfect|great)";
string input = @"I would put this on ""nothing"" since I can think of a things at that area forever";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}