package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)nothing( *)(?:^|)(new|to|at|another|really|about|perfect|great)`)
var str = `I would put this on "nothing" since I can think of a things at that area forever`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}