$re = '/nothing( *)(?:^|)(new|to|at|another|really|about|perfect|great)/m';
$str = 'I would put this on "nothing" since I can think of a things at that area forever';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);