const regex = /nothing( *)(?:^|)(new|to|at|another|really|about|perfect|great)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('nothing( *)(?:^|)(new|to|at|another|really|about|perfect|great)', 'gm')
const str = `I would put this on "nothing" since I can think of a things at that area forever`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}