using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*field\(.*; ?)(.*\))";
string input = @" field(Overdue; Overdue)
{
ApplicationArea = Suite;
Caption = 'Overdue';
Editable = false;
ToolTip = 'Specifies that the approval is overdue.';
}
field(""Table ID""; ""Table ID"")
{
ApplicationArea = Suite;
ToolTip = 'Specifies the ID of the table where the record that is subject to approval is stored.';
Visible = false;
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}