// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w*field\(.*; ?)(.*\))").unwrap();
let string = " field(Overdue; Overdue)
{
ApplicationArea = Suite;
Caption = 'Overdue';
Editable = false;
ToolTip = 'Specifies that the approval is overdue.';
}
field(\"Table ID\"; \"Table ID\")
{
ApplicationArea = Suite;
ToolTip = 'Specifies the ID of the table where the record that is subject to approval is stored.';
Visible = false;
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}