re = /(\w*field\(.*; ?)(.*\))/
str = ' field(Overdue; Overdue)
{
ApplicationArea = Suite;
Caption = \'Overdue\';
Editable = false;
ToolTip = \'Specifies that the approval is overdue.\';
}
field("Table ID"; "Table ID")
{
ApplicationArea = Suite;
ToolTip = \'Specifies the ID of the table where the record that is subject to approval is stored.\';
Visible = false;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end