import re
regex = re.compile(r"(\w*field\(.*; ?)(.*\))")
test_str = (" field(Overdue; Overdue)\n"
" {\n"
" ApplicationArea = Suite;\n"
" Caption = 'Overdue';\n"
" Editable = false;\n"
" ToolTip = 'Specifies that the approval is overdue.';\n"
" }\n"
" field(\"Table ID\"; \"Table ID\")\n"
" {\n"
" ApplicationArea = Suite;\n"
" ToolTip = 'Specifies the ID of the table where the record that is subject to approval is stored.';\n"
" Visible = false;\n"
" }")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")