const regex = /(\w*field\(.*; ?)(.*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*field\\(.*; ?)(.*\\))', 'g')
const str = ` field(Overdue; Overdue)
{
ApplicationArea = Suite;
Caption = 'Overdue';
Editable = false;
ToolTip = 'Specifies that the approval is overdue.';
}
field("Table ID"; "Table ID")
{
ApplicationArea = Suite;
ToolTip = 'Specifies the ID of the table where the record that is subject to approval is stored.';
Visible = false;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}