#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9]{2}[-][a-z0-9]{3,5}$"
Local $sString = "pk-bkf" & @CRLF & _
"id-6236" & @CRLF & _
"ew-43950" & @CRLF & _
"8q-iak" & @CRLF & _
"q2-274" & @CRLF & _
"pk-gjr" & @CRLF & _
"id-12345" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")