import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{2}[-][a-z0-9]{3,5}$";
final String string = "pk-bkf\n"
+ "id-6236\n"
+ "ew-43950\n"
+ "8q-iak\n"
+ "q2-274\n"
+ "pk-gjr\n"
+ "id-12345\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}