re = /^[a-z0-9]{2}[-][a-z0-9]{3,5}$/m
str = 'pk-bkf
id-6236
ew-43950
8q-iak
q2-274
pk-gjr
id-12345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end