use strict;
my $str = 'pk-bkf
id-6236
ew-43950
8q-iak
q2-274
pk-gjr
id-12345
';
my $regex = qr/^[a-z0-9]{2}[-][a-z0-9]{3,5}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}