// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]{2}[-][a-z0-9]{3,5}$").unwrap();
let string = "pk-bkf
id-6236
ew-43950
8q-iak
q2-274
pk-gjr
id-12345
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}