#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9](?:[ -]?[0-9]){0,14}$"
Local $sString = "12 57 125-98-457" & @CRLF & _
"12-28-35-74-12" & @CRLF & _
"12 28 35 74 12" & @CRLF & _
"123-478 25 12 124-15" & @CRLF & _
"123456789012345" & @CRLF & _
"1 2 3 4 5 6 7 8 9 0 1 2 3 4 5" & @CRLF & _
"1X2" & @CRLF & _
"1234567890123456" & @CRLF & _
"123-478 25 12 124-156"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")