import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9](?:[ -]?[0-9]){0,14}$";
final String string = "12 57 125-98-457\n"
+ "12-28-35-74-12\n"
+ "12 28 35 74 12\n"
+ "123-478 25 12 124-15\n"
+ "123456789012345\n"
+ "1 2 3 4 5 6 7 8 9 0 1 2 3 4 5\n"
+ "1X2\n"
+ "1234567890123456\n"
+ "123-478 25 12 124-156";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}