import re
regex = re.compile(r"^[0-9](?:[ -]?[0-9]){0,14}$", flags=re.MULTILINE)
test_str = ("12 57 125-98-457\n"
"12-28-35-74-12\n"
"12 28 35 74 12\n"
"123-478 25 12 124-15\n"
"123456789012345\n"
"1 2 3 4 5 6 7 8 9 0 1 2 3 4 5\n"
"1X2\n"
"1234567890123456\n"
"123-478 25 12 124-156")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")