using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9](?:[ -]?[0-9]){0,14}$";
string input = @"12 57 125-98-457
12-28-35-74-12
12 28 35 74 12
123-478 25 12 124-15
123456789012345
1 2 3 4 5 6 7 8 9 0 1 2 3 4 5
1X2
1234567890123456
123-478 25 12 124-156";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}