const regex = /^[0-9](?:[ -]?[0-9]){0,14}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9](?:[ -]?[0-9]){0,14}$', 'gm')
const str = `12 57 125-98-457
12-28-35-74-12
12 28 35 74 12
123-478 25 12 124-15
123456789012345
1 2 3 4 5 6 7 8 9 0 1 2 3 4 5
1X2
1234567890123456
123-478 25 12 124-156`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}