# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https:\\/\\/www.myurl.com\\/)([A-Za-z0-9-]+)(\\/\smarker needle)//gm;t' <<< "line = '[text] something - https://www.myurl.com/test1/ lorem ipsum https://www.myurl.com/test2/ - https://www.myurl.com/test3/ marker needle - some more text at the end'
"