const regex = /(https:\/\/www.myurl.com\/)([A-Za-z0-9-]+)(\/\smarker needle)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/www.myurl.com\\\/)([A-Za-z0-9-]+)(\\\/\\smarker needle)', 'gm')
const str = `line = '[text] something - https://www.myurl.com/test1/ lorem ipsum https://www.myurl.com/test2/ - https://www.myurl.com/test3/ marker needle - some more text at the end'
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);