use strict;
my $str = 'line = \'[text] something - https://www.myurl.com/test1/ lorem ipsum https://www.myurl.com/test2/ - https://www.myurl.com/test3/ marker needle - some more text at the end\'
';
my $regex = qr/(https:\/\/www.myurl.com\/)([A-Za-z0-9-]+)(\/\smarker needle)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";