$re = '/(https:\/\/www.myurl.com\/)([A-Za-z0-9-]+)(\/\smarker needle)/m';
$str = 'line = \'[text] something - https://www.myurl.com/test1/ lorem ipsum https://www.myurl.com/test2/ - https://www.myurl.com/test3/ marker needle - some more text at the end\'
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;