import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\[[^a-zA-Z0-9]*\\]\\.{1})(\\.{1}\\[[a-zA-Z0-9]*\\]\\.{1})*";
final String string = "<[{]..[7]..[]..[]..[C2I43].\n"
+ "<[(_#/}$)$]..[GO5A]..[G5]..[3W4].\n"
+ "<[^]..[54]..[S].\n"
+ "<[@].\n"
+ "<[)$-{,]..[PB1N]..[R757G].\n"
+ "<[]..[]..[10]..[223F]..[GBM4].\n"
+ "<[!]..[]\n"
+ "<[)_]..[3N]..[TS]..[0NS58].";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}