const regex = /(<\[[^a-zA-Z0-9]*\]\.{1})(\.{1}\[[a-zA-Z0-9]*\]\.{1})*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\[[^a-zA-Z0-9]*\\]\\.{1})(\\.{1}\\[[a-zA-Z0-9]*\\]\\.{1})*', 'mg')
const str = `<[{]..[7]..[]..[]..[C2I43].
<[(_#/}\$)\$]..[GO5A]..[G5]..[3W4].
<[^]..[54]..[S].
<[@].
<[)\$-{,]..[PB1N]..[R757G].
<[]..[]..[10]..[223F]..[GBM4].
<[!]..[]
<[)_]..[3N]..[TS]..[0NS58].`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}