import Foundation
// WARNING: You included a flag that Swift doesn't support: D
// When this flag is set, it forces the a dollar sign ('$'), to always match end of the string, instead of end of the line. This option is ignored if the 'm' flag is set.
// There's no equivalent implementation of this flag in Swift, but you may want to check the 'm' flag instead.
let pattern = #"(<\[[^a-zA-Z0-9]*\]\.{1})(\.{1}\[[a-zA-Z0-9]*\]\.{1})*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<[{]..[7]..[]..[]..[C2I43].
<[(_#/}$)$]..[GO5A]..[G5]..[3W4].
<[^]..[54]..[S].
<[@].
<[)$-{,]..[PB1N]..[R757G].
<[]..[]..[10]..[223F]..[GBM4].
<[!]..[]
<[)_]..[3N]..[TS]..[0NS58].
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)